top of page

Market Research Group

Public·14 members Install For Winn7

I have access to a local admin account which I can run elevated, and I can easily grab the required .cab files. Is there a simple way to install them in such a way that the .inf file is respected? The .inf files in question contain hooks to control the installation so I would rather not simply call regsvr32 on the contained .ocx files. Install For Winn7

This question has been marked as a duplicate and it certainly appears similar to the original question, but in my scenario I have access to a local admin account so my question is specifically about emulating the IE installation process rather than overcoming UAC restrictions. @Ben suggested a solution using advpack (via rundll32) but I have been unable to get this to work in my environment, although I will continue to investigate.

In the meantime I have been able to implement a brute-force method which exactly replicates the installation behaviour using IE. This entails locating and extracting files to the "Downloaded Program Files" directory, calling regsvr32 on the extracted ocx/dll files, and then adding entries to the following registry locations:

You simply need to work out the correct command line to do an administrative install of the component and you can add this into a logon script or similar. Once the component is installed "for all users" then the problem should go away.

By default Internet Explorer disable running unsigned ActiveX controls. Unsigned ActiveX controls are programs that tries to execute a command on your PC, like CAB install files or a ZIP file which do not have a digital signature.

I've installed this in the past and it's worked without issue. When trying to connect to the DVR, if the ActiveX control isn't installed it tells you to download it and sends you to the file. Once you download it and run it in installs a small program and the ActiveX control. What I'm getting is the program is installing, but not the ActiveX so IE still won't open the site.

We have this issue with speco camera systems. All of the files needed are kept in cab files when the activex install comes up (at least for speco). I manually extract the cab files contents to a directory. Then run regsvr32 on all of the .dll files and the .ocx files in that directory(from a cmd window run as administrator). If you cannot identify the cab files - maybe you can find on the old machine.

Is the ActiveX control signed properly? If not, IE probably wouldn't allow the install unless you add the site to Trusted, and change some settings regarding how stringently IE checks ActiveX controls before allowing them to load.

I'm not sure... I know that in the past (on 7 and XP) I didn't have to change anything to install it. And I'm not getting any kind of error message about it - it just doesn't seem to be trying. But maybe it's being blocked in the background. I'll lower settings and see what happens.

At one of our locations, we have a DVR that records video from 4 cameras. It's viewable over the network through IE. It is ONLY viewable through IE due to the fact that it uses an ActiveX control known as I've tried everything to get it to work on my computer. I've enabled everything that has to do with ActiveX controls and given full permission for the site to install whatever it needs to. But all I get is this:

check you software disc most of the time it the compatibility mode if you are using IE 10 or later you have to add the IP address instead of clicking an auto run all in compatibility mode like in IE9 it is really common in security software across the board also if you are running Win7 Ent or equivalent and you are on a VLAN system enable permissions for IE for local, domain, and private. some times depending on how your network is configured it will see the video as a "local Asset" or "private asset" instead of part of a domain device. All security software is kinda of a pain to install in an enterprise environment especially since things have moved toward AD.

If anyone still needs this, your C:\Windows\SysWOW64 is a file called HiDvrOcx.ocx, delete it and have the addin reinstalled, for some reason win7, winvista, on like 40 % of the machines the addon gets corrupted on download from your dvr, dunno why, dont understand it either.

hi, I have a 4 channel DVR system from harbor freight "Bunker Hill Security" brand. I think it is similar to those mentioned in that it uses the same activex plugin (dvrocx but I have the same problem. The activex plugin installed fine as far as I know, and I can login to the dvr fine. I can change settings, and even hear the audio from the microphone if I click on the camera image that the audio is associated with, but each camera image is just solid grey. It came with a separate PC application called NetViewer.exe, and from that program I can view all cameras and audio just fine, and review any recorded files. I have tried using IE9 on two different PC's (one Vista 32-bit, the other win 7 64-bit) and both have the same grey screen result in IE. I tried removing and reinstalling the activex control (as suggested by lynksis2011), and setting security settings to a low with DVR IP address added to trusted sites (as suggested by rabsters), but no change. I do not have a 2nd monitor on either of the computers on which it is not working. I know that the dvr does use multiple ports for control and video, but I would think the activex control should handle that once I log in. I want to be able to view the on PC's without installing the Netviewer software because I can't find my original install cd with that software on it. If anyone can find a download link for that software that would be an acceptable workaround. I haven't been able to find it yet. I'll post the link if I do, since it would likely work for others who have similar DVR's and need a workaround for the IE problem.

For background, I have a Zmodo DVR trying to access the webclient on a Windows 8/Internet Explorer 11 machine. I had changed security settings to allow for unsigned ActiveX control to download etc., added the page to compatibility view, launched IE from Program Files x86\Internet Explorer folder as administrator so it would use 32 bit version of IE, confirmed that RSVideo.ocx ActiveX add on was installed and loaded, and registering the .ocx by using regsvr32. All this would got me to a point where i could see the login page for the DVR but when i put in my password and hit login button it would just sit there. I read somewhere about entering developer mode using F12 and setting it to IE 8. Doing this did seem to activate the Login button but it would immediately crash the browser. Thanks again Hazed6809 - your suggestion forces IE 8 but it doesn't crash and logs me in properly to see the video streams properly.


Welcome to the group! You can connect with other members, ge...
Group Page: Groups_SingleGroup
bottom of page